95 370 Sundancer system questions

Discussion in 'General Maintenance/Repair Questions' started by AMFM3, Apr 17, 2012.

  1. AMFM3

    AMFM3 Active Member

    Mar 11, 2012
    Okanagan Lake, British Columbia
    370 Sundancer 1995 Raymarine C 120 Plotter / Radar
    Dinghy with 9.9 hp Merc
    454's
    7.4 L Twin inboards, v drives
    I have owned this new to us Sea Ray for a little over a month now. To date, new cockpit carpets ordered plus a new port side sun pad to go with the centreline one and other custom starboard cushion. We've spent a whack of time cleaning, getting ready for the weather to break here in the Okanagan.

    I fired it up today for the first time since we had it summer-ized and noticed a couple of things that may be issues, may not.

    1) The shower sumps, which are set to Auto, have a system light on the dash. When the batteries are on and the engine is running it flashes intermittently. Is this a sump issue or normal?

    2) Both battery gauges on the dash register nothing. I've had one or the other go on previous boats but never had both not work or move. I'm wondering if there's a switch on the panels I've missed, or a breaker in the engine compartment I can't find.

    The rumours are true...the tachs in Sea Rays are a PITA! Different set point at shutdown each time...contact cleaning time me thinks!

    Any advice or opinions from your experience would certainly help.

    Thanks.

    Mark
     
  2. mboater95

    mboater95 New Member

    75
    Dec 7, 2010
    Lake St Clair, MI
    Boatless
    Boatless
    Hi Mark,

    First I think you have a loose connection for the sump, that is not normal. Mine comes on only to discharge the water and sometimes when I go onto plane.

    No other breaker for the gauges, sounds like bad connections, the tachs you can try to turn the selector switch on the back a few times that fixed my problem!

    I have the same boat and love it :smt038

    Marty
    St Clair Shores, MI
     
  3. AMFM3

    AMFM3 Active Member

    Mar 11, 2012
    Okanagan Lake, British Columbia
    370 Sundancer 1995 Raymarine C 120 Plotter / Radar
    Dinghy with 9.9 hp Merc
    454's
    7.4 L Twin inboards, v drives
    Hey Marty...thanks for the tips. I'm also going to check the pump itself thanks to Sea Ray Mark.

    I found out today a wire was replaced on the bow thruster. Maybe over heating there damaged the sump wire.

    I'll let you know how it works out. Former owner Jeff is coming down Sunday to go over everything with me as well, so might find some tricks there.

    Mark


    Sent from my iPhone using Tapatalk
     

Share This Page

Show Sidebar