blackbeard
Last Activity:
Apr 12, 2015
Joined:
Apr 2, 2010
Messages:
43
Likes Received:
0
Trophy Points:
0
Location:
Hampton,Va.
Occupation:
construction worker

Share This Page

blackbeard

New Member, from Hampton,Va.

blackbeard was last seen:
Apr 12, 2015
    1. blackbeard
      blackbeard
      After replacing lots of parts and hiring different boat mechcanics and me knowing little about why I could not get the boat to run as expected , I found that the problem was a ground wire from the battery to the engine block .
    2. blackbeard
      blackbeard
      Hello to all,Hope your boating has gone well .however mine has been slow . Real Slow as my boat will not run faster than 8 to 10 knots .Feels like its stick in first gear. Okay I have heard that the props are fouled but is not the cAase. Switched from 3 blade to 4 blade plus pressure wash in may and still know help.Engines dont burn oil,so what could be the problem? Looking for help
    3. rcknecht
      rcknecht
      I have not noticed any rust on them, but I have looked at the engines since December.
    4. JUST PULLIN MY DINGHY
      JUST PULLIN MY DINGHY
      sorry i just found this message in my stats drop me a pm be happy to talk to a fellow 305 owner. Ernie
  • Loading...
  • Loading...
  • About

    Location:
    Hampton,Va.
    Occupation:
    construction worker
    Boat Info:
    305 Sedan Bridge 1988
    Boat Brand:
    SeaRay
    Engines:
    mercruiser twin 350s,straight drives
    boating,fishing,grilling on the boat
Show Sidebar