Steering wheel with excessive play

Discussion in 'Announcements & FAQs' started by scoutaroo, Apr 17, 2015.

  1. scoutaroo

    scoutaroo New Member

    27
    Oct 5, 2013
    north alabama/tennessee river
    Name: AM ARGO, '00, 210 BR signature series, captains chair option with jump seats in back. Shorelan
    5.7L gm
    My 210 has the steering wheel connected through a tilt mechanism to the back mounted Teleflex rack system. The excessive play in the steering wheel on examination looks to be at the connection behind the wheel to the shaft to the rack. Do you just pry out the center SR button to access the nut and where else behind the tilt mechanism could there be play. Its not the rack or cable but at the steering wheel connection to the shaft to the rack.
     
  2. jgarko

    jgarko Member

    46
    Nov 22, 2011
    florida west coast
    240 sundeck 2007 350 mag BravoIII
    350 mag MPI Bravo III
    Sounds like the same problem my 2007 240 SunDeck had. The steering wheel would actually wobble around a bit. The center nut was checked and tight. The Tilt mechanism between the the wheel and the rack had to be replaced. Now tight as when I first bought her!
     
  3. Z-Worthy

    Z-Worthy Member

    380
    Jun 20, 2014
    Sandusky, OH
    1997 400 DA
    300hp CAT 3116s
    I had to replace my entire tilt mechanism because I ignored that extra play and figured it was just a nuisance. Well, eventually one of the bolts/screws that holds the tilt mechanism backed out and pinned the wheel on the centerline. Of course this happened about 20mi away from home, so I had to bring it back to my slip with only throttles. My advice: get it fixed sooner rather than later.
     
  4. mquiet

    mquiet Member

    981
    Aug 4, 2009
    North carolina
    1999 480 Sedan Bridge
    Caterpillar 3196
    Can you define play in the wheel. I have had 2 searay a and I find both boats the wheel can move left and right by about 1/8turn and it will rock back and forth about half inch. They both had done so, so I have not done anything either. Then other than tightening the bolts behind emblem is there a better way?


    Sent from my iPhone using Tapatalk
     

Share This Page

Show Sidebar