Smart Craft Fuel display issue

Discussion in 'Sport Cruisers' started by Amberjack03, Jul 12, 2018.

  1. Amberjack03

    Amberjack03 New Member

    3
    Jul 26, 2015
    Upper Pond at Pt Judith, RI
    2003 SeaRay Amberjack 290
    Twin 5.7 Mercruiser Horizons with V-Drive Inboards
    I have a 2003 Amberjack 290 with the 350 Mags and V-drives. Late last fall, my starboard fuel gauge (analog) stopped reading the fuel level. I ordered a new fuel tank sending unit and had it installed only to find out that there is an issue with the SmartCraft unit not reading the fuel level and thus my analog gauge does not work because of it. Does anyone know how to check out what is wrong. There is no error messages and I can check/see my port fuel levels on the display but the starboard reading does not even display at all. Is there a maintenance or repair/replacement option with this unit ? Please advise.
     
  2. MiLoII

    MiLoII Member

    31
    Jul 14, 2017
    Southern Lake Michigan
    320 Sundancer 2005
    Previously 300 Doral 1999
    350 Mag MPI Inboard V Drives
    Very interesting post. This season I noticed that my starboard engine was using more fuel than the port, or so I thought based on vuth the smart craft readout and the analogue gauge showing same readings. Then I topped off the tanks expecting to put about 30 gallons in port tank and about 40 in starboard tank. I was pretty shocked when both tanks took the same amount t of fuel. So then I was thinking sender issue on starboard tank. So I find you post interesting and wonder if it's a bug in the smart craft. I have to see if there is a way to recalibrate it.
     

Share This Page

Show Sidebar