Low Voltage Warning

Discussion in 'General Discussion' started by Dmarks230, Mar 28, 2020.

  1. Dmarks230

    Dmarks230 New Member

    2
    Mar 28, 2020
    2018 230 SLX
    Mercruiser 300
    2018 230 SLX

    Rockford Fosgate stereo is on and connected but no sound and it’s displaying a “Low Voltage Warning”. Any one with experience able to point me in the right direction?
     
  2. Lazy Daze

    Lazy Daze Well-Known Member TECHNICAL Contributor GOLD Sponsor

    Apr 21, 2009
    PA
    Various
    Various
    Does it fix itself if the engine is running? If yes, check battery voltage/condition/charge. If it doesn't, then look at all connectors associated with stereo.
     
  3. Dmarks230

    Dmarks230 New Member

    2
    Mar 28, 2020
    2018 230 SLX
    Mercruiser 300
    Same issue with the engine running. I will check that out.
     
  4. Lazy Daze

    Lazy Daze Well-Known Member TECHNICAL Contributor GOLD Sponsor

    Apr 21, 2009
    PA
    Various
    Various
    You're under warranty - so don't go too far on your own, if you don't want to. Contact your local SR dealer for help.
     
  5. stephens013

    stephens013 Active Member

    440
    Oct 8, 2009
    Ft Walton Beach, Fl
    2001 510 Sundancer
    1997 400DA Sundancer
    1994 Chalarral 310 Signature
    3196 Cat; 660 PHP
    3116 Cat; 340 PHP
    I've done a radio or two and it sounds like a faintly ground, be that wiring or unit internal. If its a warranty issue then have it taken care of by the vender. For sure don't go doing anything that would adversely affect the warranty
     
    Last edited: Mar 30, 2020

Share This Page

Show Sidebar