Faria Depth Sounder Wiring Question?

Discussion in 'Electronics Q&A' started by Drumbum77, Mar 3, 2018.

  1. Drumbum77

    Drumbum77 New Member

    16
    Jan 20, 2018
    2007 Sea Ray 185 Sport 4.3TKS 190HP
    4.3L Mercruiser Alpha One 190HP
    So, I picked up a Faria depth sounder for my 2007 185 and finished installing it into the dash without a problem. :D

    After wiring the purple "POWER" wire to the 15A ignition on the block and the black "GROUND" wire to the ground post under the dash, the unit wouldn't power on? :confused: Am I missing something? This seemed pretty straight forward.

    BTW this unit matches the other gauges very well if anyone if thinking about a Faria.

    I wanted to double check with y'all on the wiring. Maybe I don't have a good ground? o_O

    Thanks
     

    Attached Files:

  2. NorCal Boater

    NorCal Boater Well-Known Member SILVER Sponsor

    Jan 24, 2008
    Covington, LA
    Cobalt CM23
    GM SB 383" Stroker" Alpha Gen I
    I just installed that same gauge in my Cobalt. Mine powered right up. I would suspect one of two things. 1. That fuse may be blown. Have you put a voltage meter on those 2 output terminals to ensure you are getting power to the gauge and, 2. The gauge may be defective. It happens. You might rig a pair of jumpers (+ & -) from a known good 12 volt source, like the battery and connect directly to the gauge. That should tell you if the gauge is bad or not. Remember, there is on-off buttons on the gauge.
    Shawn
     

Share This Page

Show Sidebar