No power to outlets

Discussion in 'Electronics Q&A' started by lakerdave, Aug 3, 2015.

  1. lakerdave

    lakerdave New Member

    1
    Aug 28, 2012
    Lake Sidney Lanier, Georgia
    83' Weekender Vanguard (light blue)
    twin 260 closed-loop Merc 350's
    Shaft drive, generator, heat/
    twin 260 hp. Merc 350's. (shaft drive)
    All A/C outlets, quit working. Found only one GFCI outlet in bathroom that would not reset, so I replaced. New outlet has a little green light that IS on. Still no power to that or any other outlets. Of course, panel is reading 120 volts coming in on shore power, and all breakers are on. Air conditioner is working, as well as electric burners. Converter does not contain any indicator lights or fuse/breakers, but do not believe it is charging batteries. Any ideas?



    1983 310 Vanguard
    (light blue)
    twin 350 260hp shaft drive.
     
  2. JVM225

    JVM225 Well-Known Member

    Apr 8, 2008
    Farmingdale, NY
    2002 410 Sundancer, Monaco Edition.
    3126 Cats.
    The GFCI should be the first receptacle after the panel. It's job is to protect the panel.
    They do go bad once in a while. You say that the replacement has a green indicator that is illuminated. that means there is power to that GFCI receptacle. If none of the others on that circuit have power, then I would check to make sure the GFCI is wired properly. Did you replace everything exactly the way it was hooked up to the old one?
     

Share This Page

Show Sidebar