Mercruiser parts inaccurate motor

Discussion in 'General Maintenance/Repair Questions' started by Climate East, Jul 5, 2019.

  1. Climate East

    Climate East New Member

    19
    May 14, 2018
    Greenville NC
    1997 330 DA
    1999 280 BR
    7.4L V-drives
    hi everyone, I have. 1999 280BR that has twin 5.7 TBI motors. Serial number on the starboard motor is 0L349745 which comes up as a Gen+ and port motor is very close in sequence just don’t have it with me at the moment. My problem is mercruiserparts.com says this motor has a belt driven raw water pump which seems to be missing off of both of the motors. Perhaps they fell off and are laying in the bilge or the website just has it completely wrong. Just looking for tre correct impeller part number for the Alpha drive instead of pulling the lower off to find it. Anyone ever run into the issue where the serial number doesn’t match the engine from the website?
     
  2. Craig

    Craig Well-Known Member GOLD Sponsor

    540
    Feb 8, 2007
    Maryland
    2006 320 Sundancer
    twin 350 Horizon V drives
    The engine diagram is showing a belt driven pump for the b3. Alpha has the pump in the drive. Look up the alpha drive diagram for the pump parts.
     
  3. scoflaw

    scoflaw Well-Known Member

    Aug 10, 2011
    cape cod mass, cape coral fl
    1999 Powerquest legend 260 sx
    502 mpi Bravo 1
    The site gives the option of Bravo or Alpha . Right ? Alpha's of that vintage will take the same part.
     
  4. Climate East

    Climate East New Member

    19
    May 14, 2018
    Greenville NC
    1997 330 DA
    1999 280 BR
    7.4L V-drives
    The site clearly shows that the sea water pump is belt driven. Does not state that it is for bravo drives only. Alpha drives have had it both ways. Someone please clarify this if you can. Thanks for your help.
     
  5. Craig

    Craig Well-Known Member GOLD Sponsor

    540
    Feb 8, 2007
    Maryland
    2006 320 Sundancer
    twin 350 Horizon V drives
    If your engines don't have the pumps on them then they have to have the pump is in the alpha drive, try referring that diagram for part numbers.
     
  6. Climate East

    Climate East New Member

    19
    May 14, 2018
    Greenville NC
    1997 330 DA
    1999 280 BR
    7.4L V-drives
    I guess my real issue is what else is different. I was looking to get a spare ignition coil but it doesn’t match either. I have a soft alarm at 3000 rpm and a no start condition when hot. If I need to buy the parts that I believe I need, what part numbers do I use, what engine do I look up to get these numbers. Anyone understand where I’m going with this?
     
  7. Craig

    Craig Well-Known Member GOLD Sponsor

    540
    Feb 8, 2007
    Maryland
    2006 320 Sundancer
    twin 350 Horizon V drives
    Check mercury's web site to verify Vin's. Mercuiserparts.com is a dealer and could have the wrong info.
     
  8. scoflaw

    scoflaw Well-Known Member

    Aug 10, 2011
    cape cod mass, cape coral fl
    1999 Powerquest legend 260 sx
    502 mpi Bravo 1
    You should have a Mefi 3 ecm, which is incapable of a soft alarm.
    Scroll thru that Merc site until you find the diagram that looks like what you have.
     
  9. Climate East

    Climate East New Member

    19
    May 14, 2018
    Greenville NC
    1997 330 DA
    1999 280 BR
    7.4L V-drives
    I don’t know why I didn’t think of going to their actual site. Thx for the help.
     
  10. Climate East

    Climate East New Member

    19
    May 14, 2018
    Greenville NC
    1997 330 DA
    1999 280 BR
    7.4L V-drives
    What do you mean? What kind of alarms should I get?
     
  11. scoflaw

    scoflaw Well-Known Member

    Aug 10, 2011
    cape cod mass, cape coral fl
    1999 Powerquest legend 260 sx
    502 mpi Bravo 1
    Mefi 3 is only capable of 1 tone and is limited to
    low oil pressure
    low drive fluid
    overheat
    sensor fault
     
  12. Climate East

    Climate East New Member

    19
    May 14, 2018
    Greenville NC
    1997 330 DA
    1999 280 BR
    7.4L V-drives
    I have to respectfully disagree. They have a soft alarm below 3000 rpm and a hard alarm above.
     
  13. scoflaw

    scoflaw Well-Known Member

    Aug 10, 2011
    cape cod mass, cape coral fl
    1999 Powerquest legend 260 sx
    502 mpi Bravo 1
    If the parts diagram doesn't look like the parts on your engine maybe you don't have the Mefi3 ECM.

    Post up a couple of pics.
     
  14. Climate East

    Climate East New Member

    19
    May 14, 2018
    Greenville NC
    1997 330 DA
    1999 280 BR
    7.4L V-drives
    After going to the mercury website I have found the correct ignition coil and etc... I should have thought of that sooner. Just curious why you say the mefi3 doesn’t have a soft alarm
     
  15. Bt Doctur

    Bt Doctur Well-Known Member

    Aug 21, 2010
    New Jersey
    Ex SRV 240 Weekender twin
    in between
    according to the ser # you have a serpentine belt, Yes?
    Your ecm # is listed as 861926T3
    Motor can be for Alpha or Bravo or inboard, whats yours?
    coil is listed as coil kit 805570A2
     
  16. scoflaw

    scoflaw Well-Known Member

    Aug 10, 2011
    cape cod mass, cape coral fl
    1999 Powerquest legend 260 sx
    502 mpi Bravo 1
    I have owned 1 for years and have the 2 volume #23 service manual for it. About 800 pages worth with no mention of it.
     
  17. Craig

    Craig Well-Known Member GOLD Sponsor

    540
    Feb 8, 2007
    Maryland
    2006 320 Sundancer
    twin 350 Horizon V drives
    My 2000 had one tone but it beeped for minor stuff and was continuous for more severe alerts.
     
  18. Bt Doctur

    Bt Doctur Well-Known Member

    Aug 21, 2010
    New Jersey
    Ex SRV 240 Weekender twin
    in between
    You mention Alpha so you should have the GEN II drives Quicksilver kit QSL817275A5
     

Share This Page

Show Sidebar