KVH TV1 antenna broke

Discussion in 'Electronics Q&A' started by ZZ13, May 18, 2018.

  1. ZZ13

    ZZ13 Well-Known Member GOLD Sponsor

    Nov 25, 2009
    Lady's Island, SC
    2001 400 Sedan Bridge
    Cummins 450 Diamond
    well my 2.5 year old TV1 antenna broke. Naturally the warranty is 2 years. It's the RG6 connection at the antenna. If I can't fix it myself I will be sending it back for repair. Has any ever used KVH for a repair? How did it go?
     
  2. ZZ13

    ZZ13 Well-Known Member GOLD Sponsor

    Nov 25, 2009
    Lady's Island, SC
    2001 400 Sedan Bridge
    Cummins 450 Diamond
    I found the problem. The thin shielded wire (KVH calls it a battle connector) with the yellow tape on it comes from the external RG6 connector and goes under the unit and comes back out to the internal R/J connection. It works when I bypass that extension wire and plug directly into the R/J connector. Since this rotates 360 degrees, the shielded wire is probably going into some kind of rotating connector. Now to take the unit off the case to see what's under there.
     

    Attached Files:

    Jaybeaux likes this.
  3. ZZ13

    ZZ13 Well-Known Member GOLD Sponsor

    Nov 25, 2009
    Lady's Island, SC
    2001 400 Sedan Bridge
    Cummins 450 Diamond
    Now its getting interesting. There is nothing wrong with the extension connection from the outside connector to the R/J connector shown in the picture. I verified that by doing a continuity check from the outside connector to the open end of the original connector that is unscrewed in the picture. So I am down to one of two problems. The center wire on the outside cable is not making contact inside the outside connector, or the center wire on the inside braided cable is not making connection to the inside of is mating connector. That wire is very small in diameter - about half the diameter of the test RG6 cable I have plugged into it.
     
  4. ttmott

    ttmott Well-Known Member

    Apr 3, 2012
    Space Coast Florida
    2006 52 Sedan Bridge
    Cummins QSM11
    isn't that wire part of the "clockspring" that coils up and out as the antenna rotates?
    Unless KVH changed the antenna will rotate until the limit of the clockspring is reached then will unwind and re-acquire the satellite.
    Possibly it is broken and making intermittent contact. You might put the meter on the ends of the wire and rotate the antenna to see if it is broken.... Just a thought.
     
  5. NickBOE

    NickBOE New Member

    23
    Apr 26, 2018
    C-Hawk
    Suzuki DF300AP
    Hopefully that is it Mott.
     
  6. ZZ13

    ZZ13 Well-Known Member GOLD Sponsor

    Nov 25, 2009
    Lady's Island, SC
    2001 400 Sedan Bridge
    Cummins 450 Diamond
    Thanks. I couldn't pull the unit off the base to look under there pulled all the screws out but only lifts up an inch or so. Your point makes sense. I did the continuity check after I had rotated it by hand a full turn. I'll try your test then probably just pack it up and ship it to KVH for repair.
     
  7. ZZ13

    ZZ13 Well-Known Member GOLD Sponsor

    Nov 25, 2009
    Lady's Island, SC
    2001 400 Sedan Bridge
    Cummins 450 Diamond
    Clipped the meter leads to each end of the cable and spun the antenna around 360 degrees in both directions. It never lost continuity. So I put it all back together and re-installed and it's now working fine. Guess I'll run it hard for a while and see how it holds up. Back to the beginning of the circular loop I go.....
     
  8. tc410

    tc410 Active Member PLATINUM Sponsor

    773
    Oct 9, 2006
    Charlevoix, MI/Jupiter, FL
    2005 550DB
    MAN CRM-900
    Just a thought here to consider.... if you originally bought your TV1 with a credit card, most will offer purchase protection by adding an additional year to the warranty. Your two year warranty would be three years (duh). Of course, if that’s not the case, you're totally out of pocket so hopefully your repair will be long-lasting!
     
  9. Ryanm51981

    Ryanm51981 Member

    51
    Apr 10, 2012
    Peconic Bay NY
    2006 Sea Ray 290 ---- SOLD
    2006 380 Sundancer - current
    8.1 Mercs v drives
    Ive used KVH to fix my M1 twice...its not cheap . Shipping was about 100 bucks from NY to rhode island . Same thing broke on mine twice. I had a circuit board that fried twice and they figured out the second time that I must of had a floating ground in the boat that fried the board. I wanna say it was about 250 bucks plus shipping every time it broke
     
  10. SKybolt

    SKybolt Member

    294
    Nov 11, 2014
    Long Island, NY
    1988 460 EC Sea Ray. w/12.5K Westerbeke Genset.
    Twin 6v92TA Low profile's (475hp) with Alison Gears.
    If it's not too much trouble, I would put some dielectric grease on all of the connections. It will help keep corrosion from starting. With things that new, pulling it apart and back together usually cleans the connections a bit and will start working again. The dielectric grease will help keep that connection clean.
     

Share This Page

Show Sidebar