Kohler 5ECD Not Running EC62, UU, UF

Discussion in 'Electrical Stuff' started by pyro, Apr 15, 2019.

  1. pyro

    pyro Active Member

    172
    Dec 4, 2018
    CT, Long Island Sound
    2008 Sundancer 290
    Twin 5.0L MPI Bravo III
    Kohler 5ecd
    I did use injectorRx since I couldn't find any place locally. I think it was $25 irc. They have a form you fill out, with pricing info. I think a new injector was $125 or $150. I would say it is absolutely worth it. If your pump was in bad shape it clogged the downstream injector. And the ratio of $25 to what you just spent on new pumps is minimal! Downside is it took about 1.5 weeks to ship both ways. If you can find a place locally you might go with that, but InjectorRx seemed to have some info on this injector and could verify it met original specs.
     
  2. tlrlc

    tlrlc Member

    220
    Sep 13, 2013
    Long Island, NY
    2007 310 sundancer
    mercury 6.2 horizon x 2
    vdrive/bow thruster
    great thanks for the info i am going to use them since they know the injector already.
     
  3. Bwardz50

    Bwardz50 New Member

    27
    Jul 3, 2018
    Lutz, FL
    2006 340 Sundancer
    2005 Mastercraft X2
    1995 16' Carolina Skiff
    8.1 Mercruiser Horizons with V-Drives
    MCX 350 Indmar with V-Drive
    Yamaha F40TLRC
    Probably not a huge savings for just one but I rigged up a pretty effective cleaner to do it myself. I had done this previously for my ski boat so I had 8 of them to do. The pictures are from that boat so the injector looks a little different than that on the Kohler but it worked the same way.
    I used a plastic syringe body that they gave me for my kids meds. Then inserted the red tube that comes with the carb cleaner can and used heat shrink tubing to ensure a good seal between them. Then bought the standard fuel injector electrical connector at my local auto parts store. Put the injector into the big end of the syringe and pressurize it with the carb cleaner can. Then actuate the injector with a 9-volt battery on and off very quickly several times while occasionally re-pressurizing the syringe. Flip the injector around to do it forwards and backwards. It sounds more complicated than it is but it works great and really made sense when I had 8 of them to do. I did this to my 5ECD a year ago and 100+ hours ago which reminds me that I’m due for an oil change. I did this in conjunction with replacing both fuel pumps due to internal corrosion. I’m back to troubleshooting this unit because of a recent issue with EC62. F038D7D5-0767-422D-AB70-45C87ABCAD0D.jpeg 98A62951-E688-4031-9B0B-BB8FCC3BC6E1.jpeg
     
    douglee25 likes this.
  4. Todd320

    Todd320 Well-Known Member

    Jul 21, 2016
    St. Petersburg, FL
    2007 Sea Ray 320DA
    Twin V-drive 5.7L 350 Horizon
    Any luck on the EC62? I had this happen yesterday. Basket was full, but error is still there after clearing and restarting. I’m pretty sure it’s just an impeller replacement, I’ll know more on Wednesday, after I replace on Monday and test on Wednesday.
     
  5. Stray Current

    Stray Current Member

    115
    Oct 27, 2019
    New Jersczystan
    2007 260DA
    6.2 Horizon MPI/BravoIII
    Kohler 5ECD
    For those of you that removed or changed your injectors, how much disassembly is required? Does the intake manifold have to come off? I bought a new injector but never changed it as it started running with the new pump.
     
    Last edited: May 25, 2020
  6. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    So I too, am having he EC62 and occasional LOC shut down codes.
    It actually does appear to be getting low water flow, as it is throwing steam out too. (80° today)
    I am intimately familiar with this genny as U have replaced the ADC 2100, Stator, rubber water pump/shaft coupler, impeller, ect.
    Usually runs well for 8 hours at a time.
    But now 5 mins and shut down code.
    from reading this, somewhat lengthy post, the first page about the crusty water passage in the fuel cooler, could be my problem. Check out my video. Water is extremely hot and not enough of it!
     
    Todd320 likes this.
  7. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    So, I think I will cut a piece of hose and bypass the “cool fuel” System to see if it solves the problem before I remove it.
     
    Chris-380 likes this.
  8. pyro

    pyro Active Member

    172
    Dec 4, 2018
    CT, Long Island Sound
    2008 Sundancer 290
    Twin 5.0L MPI Bravo III
    Kohler 5ecd
    Sad this thread is getting a lot of activity again :(

    @Stray Current: No the intake manifold does not need to come off. I don't quite remember the exact details, but I know nothing major is taken apart. Take the connector off, there is a C-clip that slides out. You might need to take the 2 allen head screws and maybe fuel rail compression fitting. It's a little tight, but should be obvious when you get to it.

    @speakrdude: I think you have what EC62 is supposed to direct you to: low water flow/pressure! My guess is you have a broken impeller stuck somewhere. Have you inspected impellor? You can also fairly easily backflow the heat exchanger in a closed loop out of a bucket to get rid of any junk in there.
     
    Chris-380 likes this.
  9. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    Thanks Pyro! Yes in the impeller. Since I’ve owned, four years now, I’ve never had an impeller issue. I did have a bad impeller coupler. Carry a spare for that now. I will try the reverse flow today and see if there are any restrictions. Seems like the culprit, in there somewhere.
     
  10. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    Did you mean to reverse flush with water hose or plumb the output of the water pump to it?
     
  11. pyro

    pyro Active Member

    172
    Dec 4, 2018
    CT, Long Island Sound
    2008 Sundancer 290
    Twin 5.0L MPI Bravo III
    Kohler 5ecd
    I think either way. Whatever is easiest.
    I made this video early on before I chased the problem much deeper into what became this thread. Maybe this will help:
     
    Last edited: May 26, 2020
  12. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    So I tried back flushing directly from the pump. It appears I have a low flow from the pump or thru Hull.
     
  13. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    And your video says “we’re working on processing it”
     
  14. tlrlc

    tlrlc Member

    220
    Sep 13, 2013
    Long Island, NY
    2007 310 sundancer
    mercury 6.2 horizon x 2
    vdrive/bow thruster
    i changed out the 1 injector last week it is a metal retainer clip on electric connection. 1 fuel supply line, 2 allen keys holding assembly to manifold and one more retainer clip holding injector together. its right on top of generator. use some gas to lube o rings when re assembling.
     
  15. Bwardz50

    Bwardz50 New Member

    27
    Jul 3, 2018
    Lutz, FL
    2006 340 Sundancer
    2005 Mastercraft X2
    1995 16' Carolina Skiff
    8.1 Mercruiser Horizons with V-Drives
    MCX 350 Indmar with V-Drive
    Yamaha F40TLRC
    Quick update on my EC62 issue. I disconnected the raw water hose from the output side of the pump and also from where it dumps into the exhaust. I then rigged up my garden hose to the hose that went to the exhaust and "backflushed" the system with water. There was a fair amount of pieces of impeller and seaweed that came out. My Impeller is still like new so I didnt have to replace it this time but the PO must have had an impeller come apart at some point in the past. I hooked everything back up and ran the generator for 2 hours under air conditioner load with no further issues. Looks like we're out of the woods until something else breaks on this thing!
     
  16. Stray Current

    Stray Current Member

    115
    Oct 27, 2019
    New Jersczystan
    2007 260DA
    6.2 Horizon MPI/BravoIII
    Kohler 5ECD
    3:45 am and the boat gets quiet. 5ecd shutdown in LOC fault (seawater pressure loss) won't restart. Fuse 4 blown and replacement blows immediately.

    Got into the manual and started digging. F4 is ignition coils and injector power. Dead short to ground, even with coils and injector unplugged

    looks like the coil got so hot when it melted down that it took out the plug as well, everything's melted together.

    Obviously I need a new ignition coil, and a pigtail. does anybody know if the pigtail is available separately from the entire harness or do I have to replace the assembly?

    IMG_20200531_125847.jpg IMG_20200531_125726.jpg IMG_20200531_130045.jpg IMG_20200531_130139.jpg I have almost 70 hours on this thing since I fixed it over the winter, was running good up until that point.

    I've heard of letting out the magical smoke, but I've never seen anything let out the magical marshmallow fluff...
     
  17. Bwardz50

    Bwardz50 New Member

    27
    Jul 3, 2018
    Lutz, FL
    2006 340 Sundancer
    2005 Mastercraft X2
    1995 16' Carolina Skiff
    8.1 Mercruiser Horizons with V-Drives
    MCX 350 Indmar with V-Drive
    Yamaha F40TLRC
    Looks like a GM Weather Pack connector. There are dozens of shapes and sizes but it's probably worth going to an auto parts store and try to match it up. Napa sells a bunch of different types of these. Maybe start here too: https://www.weatherpack.com/
     
    dlvwill likes this.
  18. tlrlc

    tlrlc Member

    220
    Sep 13, 2013
    Long Island, NY
    2007 310 sundancer
    mercury 6.2 horizon x 2
    vdrive/bow thruster
    i had this issue back in 2016 - try and find a GM part # 12085497 it is exactly the plug you need its used on gm cars for a mass airflow sensor.
     
  19. Stray Current

    Stray Current Member

    115
    Oct 27, 2019
    New Jersczystan
    2007 260DA
    6.2 Horizon MPI/BravoIII
    Kohler 5ECD
    Correct, I found a NOS AC Delco pt119 that matches. It's for the mass air meter on a middle to later 80s tuned port injection V8. I was going to post pictures once I had it and I was positive it matches.
     
    Last edited: Jun 3, 2020
    Todd320 likes this.
  20. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    Ta-Da!!!Turns out it wasnt is he impeller, but a blockage in the sea cock or the thru-hull.
    Replaced impeller. Same problem. Blew back at the 3/4” hose that connects sea cock to the strainer. Big bubble! Problem solved!
     
    Todd320 and Bwardz50 like this.

Share This Page

Show Sidebar