Kohler 5ecd EC62

Discussion in 'General Maintenance/Repair Questions' started by Todd320, May 23, 2020 at 8:09 PM.

Tags:
  1. Todd320

    Todd320 Well-Known Member

    Jul 21, 2016
    St. Petersburg, FL
    2007 Sea Ray 320DA
    Twin V-drive 5.7L 350 Horizon
    So, received this error today doing a pre-trip test, EC62, kohler 5ECD, 2007ish. I believe it indicates water pressure issue. I checked and there was a ton of debris in the basket, emptied that out, opened the sea cock, cranked it up, more water coming out of the exhaust, looked good. Turned on AC, and threw that error again. Checked basket, it was clean this time.
    Next steps? I will Replace impeller and oring, what about the water pressure sensor, I think it’s GM30263?
    Where would I find one before Wednesday? I’m guessing auto parts stores would not have an equivalent part?
     
  2. hottoddie

    hottoddie Well-Known Member

    Jan 11, 2012
    Boston/Cape Cod
    1986 Sea Ray 390 EC
    Garmin 4212 Chartplotter
    Garmin 24 HD Radar
    Garmin 546s Plotter
    454 Crusaders
    When it threw the code again did it shut down? If it kept running I would let it run. The code may clear later. Damn Kohlers are a PITA
     
    Todd320 likes this.
  3. Todd320

    Todd320 Well-Known Member

    Jul 21, 2016
    St. Petersburg, FL
    2007 Sea Ray 320DA
    Twin V-drive 5.7L 350 Horizon
    It shut down both times, the first time made sense, the basket was full of crap.
    Thought for sure it would work the second time. To reset, I had to turn the 12v battery switches off then on, that clears the code until I crank it again.
     
  4. Todd320

    Todd320 Well-Known Member

    Jul 21, 2016
    St. Petersburg, FL
    2007 Sea Ray 320DA
    Twin V-drive 5.7L 350 Horizon
    Here is what I found in the service manual
    EC62 Seawater Pump Pressure
    Fault appears when seawater cooling is lost. Check the seawater strainer for clogged material. Check the seawater pump impeller. Check if wire 215 is shorted to ground. I did 1, I’ll do 2 next, have no idea what wire 215 is, not referenced in the manual that I could find.
    I did find a separate test for the water pressure sensor and where it’s located.
     
  5. MikeBravo

    MikeBravo Active Member

    202
    Jan 20, 2016
    Treasure Island, FL
    2007 Sundancer 320
    2019 Edgewater 158cs
    1988 Grady White 24 Offshore(sold)
    DA-Twin 350 MAG MPI Mercruisers, V-drive
    Edge-Yamaha 70HP 4-Stroke
    Are you sure the seawater pump is working properly. I have the same year boat and genny, my seawater pump completely froze and I had to replace.
     
    Todd320 likes this.
  6. Todd320

    Todd320 Well-Known Member

    Jul 21, 2016
    St. Petersburg, FL
    2007 Sea Ray 320DA
    Twin V-drive 5.7L 350 Horizon
    Well, when it was running, I had water exiting the exhaust, the flow wasn’t high enough initially, much more exiting exhaust after I removed the debris, and I thought it was enough, but under load, gave error again.
     
  7. MikeBravo

    MikeBravo Active Member

    202
    Jan 20, 2016
    Treasure Island, FL
    2007 Sundancer 320
    2019 Edgewater 158cs
    1988 Grady White 24 Offshore(sold)
    DA-Twin 350 MAG MPI Mercruisers, V-drive
    Edge-Yamaha 70HP 4-Stroke
    How clean is the heat exchanger?
     
  8. JimT

    JimT Well-Known Member GOLD Sponsor

    Jul 7, 2009
    Charlotte, NC- LKN
    2010 330 Sundancer
    T-350mags w/BIIIs & Axius, 5.0 kw Kohler
    You may have lost the prime. Go for a ride and start the genny while underway. This will force water into the intake and remove any air.
     
  9. skolbe

    skolbe Well-Known Member

    Oct 3, 2006
    St. Louis, MO
    320 Sundancer, Mercury 310 Sport Inflatable Tohatsu 6HP
    350 Mag V-Drive - Kohler 5ecd
    Every time on my 07 - there is something stuck in the elbow above the seacock. Water still flows but not enough so it shuts down. The easy way to tell is run it and if you can't put your hand in the exhaust water. It has an obstruction.
     
    Todd320 likes this.
  10. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    Having the exact, low flow condition on my Kohler 5ECD, and throwing EC62. 6 page post about this genny, in the electronics page on this forum.
    I checked all the way back to the pump. Impeller looks fine. Strainer is clean. Will tank hose off sea cock next. Is pumping, just not enough.
     
    Todd320 likes this.
  11. hottoddie

    hottoddie Well-Known Member

    Jan 11, 2012
    Boston/Cape Cod
    1986 Sea Ray 390 EC
    Garmin 4212 Chartplotter
    Garmin 24 HD Radar
    Garmin 546s Plotter
    454 Crusaders
    Just because the impeller looks ok doesn't mean it is. They are cheap and easy to replace. If I had a Kohler I'd replace it every year. They are very fussy animals and very little room for error.
     
    Todd320 likes this.
  12. Todd320

    Todd320 Well-Known Member

    Jul 21, 2016
    St. Petersburg, FL
    2007 Sea Ray 320DA
    Twin V-drive 5.7L 350 Horizon
    Replaced the impeller today and o-ring, did not put the boat in the water to test, so that will happen on Wednesday.
     
  13. Todd320

    Todd320 Well-Known Member

    Jul 21, 2016
    St. Petersburg, FL
    2007 Sea Ray 320DA
    Twin V-drive 5.7L 350 Horizon
    So “Above seacock” == between the intake and the seacock? And you test this by checking the temperature of the exhaust water, too hot to touch or it peels your skin off, obstruction, if it’s 100-ish, good to go? I have had this occur before, but it was gunk underneath the boat, cleaned it and the strainer, worked fine the next 18 hours.
     
  14. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    I ordered new impeller and instal as soon as it arrives. The water is deff to hot to touch!
     

Share This Page

Show Sidebar