Bilge Paint, peeling

Discussion in 'General Maintenance/Repair Questions' started by kysearay, Jan 28, 2018.

  1. kysearay

    kysearay Member

    47
    Jun 15, 2017
    KY
    42 Sundancer
    8.1's gassers
    Hello all,
    Winter here in KY and thinking about all the punch list items I want to start up in the Spring. My '05 420 DA is having some paint peeling (is it really paint or gelcoat?) around some of the bilge pumps. Dont know if this is something i should be concerned about and if so how would i repair/reglass??
    Thanks all
    Chris
     
  2. Little Ducky

    Little Ducky Active Member

    513
    Jun 5, 2017
    Chattanooga TN/Dickson TN
    1998 SeaRay 290 Sundancer
    Twin 5.0L w/Alpha 1 drives
    Post some pictures.

    There are a few post on CSR about paint pealing in the bilge area.
     
    Last edited: Jan 28, 2018
  3. kysearay

    kysearay Member

    47
    Jun 15, 2017
    KY
    42 Sundancer
    8.1's gassers
    I will get some, she is shrink wrapped for the winter, thanks.
    chris

    Found the other threads and responded there - well this will be fun this spring.
     
    Last edited: Jan 28, 2018
  4. JC3

    JC3 Active Member

    Oct 6, 2006
    Kentucky
    N/A
    N/A
    Chris, Another KY old Sea Ray guy here. Do you have any pictures of this? JC
     
  5. MojoHaiku

    MojoHaiku New Member

    24
    May 27, 2012
    Anderson, SC
    2005 Sea Ray 420 Sundancer
    Meli’s Gringo
    Mercruiser 8.1 HO
    I have the same boat and same issue... One small area, maybe 3.5" diameter right under the DC breaker panel in the bilge... Primer and the correct paint seem to be very expensive at first glance... And prepping the area properly is critical based on the tiny little bit I've read. I'm going to monitor this thread and see what others with experience say...
     

Share This Page

Show Sidebar