ATC Installation Tips?

Discussion in 'Bennett Trim Tabs Vendor Forum' started by MikeWood, Aug 5, 2014.

  1. spikedaddy99

    spikedaddy99 Member GOLD Sponsor

    610
    Jun 11, 2008
    Prentice, Wi
    2007 320DA
    Twin 350 Mercs/V-Drives
    To revive this thread, has anyone installed the ATC on 2007 or newer with the trim integrated in the whole touchpad? Touchpad has 4 wires coming out of the rear, but controls tabs, hatch, bilge blower and bilge pump. I've talked with Tom, and the thought is to find the Bennett wires somewhere further back in the system. Do I look at the breaker panel in the bilge to find the red/blue/green/yellow wire bundle?
    IMG_1170.jpg IMG_1172.jpg
     
  2. alnav

    alnav Member GOLD Sponsor

    789
    Sep 16, 2009
    West River, MD
    40 MY
    QSB 425
    While I had only one control on my 2008, I did have to deal with a Sea Ray-installed wiring run that was colored differently from the Bennet harness. They apparently installed a run/harness as part of the initial wiring package. That could be true of yours. The Sea Ray wiring started just forward of the Bennet pump on the aft transom. You might start looking there on yours to see if there is a transition from the trim tab wiring to an installed run and note the wire size/coloring. If there is, it probably emerges again near the dash and thence to the integrated control and you might be able to tap for your new control from the transition point.
     
  3. Tabman

    Tabman Member

    676
    Jan 11, 2007
    The Tab Cave
    boatless
    boatless
    As Al points out go aft to the pump and follow the blue, yellow, red and green wires forward. SeaRay had us supply many pumps without a connector on the wire harness so that they could connect their own harness to it. That would mean that the connection could be within two feet of the pump.

    Tom
    Bennett Marine
     
  4. spikedaddy99

    spikedaddy99 Member GOLD Sponsor

    610
    Jun 11, 2008
    Prentice, Wi
    2007 320DA
    Twin 350 Mercs/V-Drives
    Well, I finally got my ATC working. I created 2 wire bundles to run back to where the pump is and was able to get it working. A little more convoluted on a 2007.
    IMG_2119.jpg

    Making wiring harness

    IMG_2123.jpg

    Control installed.
     

Share This Page

Show Sidebar