390 EC Front A/C Problem

Discussion in 'Beard Marine Vendor Forum' started by Express 390, Sep 20, 2018.

  1. Express 390

    Express 390 Member GOLD Sponsor

    85
    Sep 14, 2018
    South Shore of Long Island NY
    1986 SeaRay 390 EC
    Twin 454 Crusaders inboards 4 blades
    A friend of mine with with a 1988 SeaRay390 EC is having a problem with the front A/C I'm not getting any power to the Compressor but the fan runs its a tuff unit to work on I'm thinking maybe a relay but can't find it, or a start capacitor. Am i warm and on the right track?
     
  2. gdavis67

    gdavis67 Active Member

    111
    Mar 1, 2017
    Saugatuck, MI
    1990 390ec
    Twin 454 Mercruiser T 340 with Hurth drives
    Move this to the Classic forum or more specifically the 390EC page and you will likely have better response than here.

    Any time the system is "on" at the rheostat dial, the fan is on. If either unit is calling for heat/cool, the pump is on. There is a small board on top of the A/C unit that has all of the electrical connections on it under a sheet metal guard, that is where you will need to start your diagnosis of the problem. There is an old manual online somewhere (can't remember where and I didn't save it) that shows the wiring schematic for this unit. Start with that.

    Good luck.
     
    Express 390 likes this.
  3. Express 390

    Express 390 Member GOLD Sponsor

    85
    Sep 14, 2018
    South Shore of Long Island NY
    1986 SeaRay 390 EC
    Twin 454 Crusaders inboards 4 blades
    Thanks so much!
     

Share This Page

Show Sidebar