215 Express Cuddy Lights

Discussion in 'Blog' started by Afrenzel, May 6, 2010.

  1. Afrenzel

    Afrenzel New Member

    4
    May 6, 2010
    Rochester, ny
    215 Express Cruiser 1995
    220 Mercruiser
    I have a 1995 Express Cruiser and I am trying to turn on my cuddy lights. There are three light, all with individual switches and none of them work. I have replaced them with new 12v light bulbs and they still don't work. I even tested the electric current on each individual light and it is fine. Does anyone have any suggestions? Am I missing something? All suggestions are welcome!!!
     
  2. Lazy Daze

    Lazy Daze Active Member TECHNICAL Contributor GOLD Sponsor

    Apr 21, 2009
    PA
    Various
    Various
    Do you have power to other 12v things?

    If I remember correctly, there is no 12v breaker panel, correct? Meaning your battery switch basically functions as the master on/off control?

    You tested and got 12v at the socket?

    Are you using bulbs with the correct base (single of double contact)?

    This shouldn't be too hard to figure out - must be something simple.
     
  3. Afrenzel

    Afrenzel New Member

    4
    May 6, 2010
    Rochester, ny
    215 Express Cruiser 1995
    220 Mercruiser
    I do not know if anything else is 12v, to be honest. I would think that my navigation lights are 12v but I am not sure. There is no 12v breaker panel, I think the only power switch is on the batter switch. I did not test for 12v, just for power. I know they are 12v because it says 12v in the manual. I am using single base and I think that is correct since there is a single connector in the socket. I think it is something simple as well. Would it matter if I was not connected to shore power?
     
  4. KC WV

    KC WV Member

    97
    Feb 27, 2008
    Huntington, WV
    215 EC 1997
    350, Alpha
    They should be on if your battery switch is on. Maybe wrong bulbs. Are they fused? The fuse panel is behind the access hatch over the head. Four screws and remove the rectangular cover. But if you're getting 12V at the light socket, it has to be the bulbs.
     
  5. Afrenzel

    Afrenzel New Member

    4
    May 6, 2010
    Rochester, ny
    215 Express Cruiser 1995
    220 Mercruiser
    Thats what I was thinking but I checked all the fuses and the bulbs are 1411LL, which I believe are the right bulbs. I don't know what it could be. Thanks for the response guys.
     

Share This Page

Show Sidebar