2006 8.1L Injector Issue?

Discussion in 'Sport Cruisers' started by TheBobC, Aug 17, 2019.

  1. TheBobC

    TheBobC New Member

    27
    Sep 21, 2017
    Pompano Beach, FL
    2006 340 Sundancer with Sportsman Package
    Original C80, Raymarine Radar and ST6001 Auto Pilot
    8.1 Horizons
    Having a rough summer (as referenced in another thread) engine-wise. Latest issue...I pulled the injectors on both engines on my 06 340. Had them serviced and while I was told they were pretty rough, they all came out good. When I put them back in today...upon starting the engines there was a heavy gasoline sheen from both engine exhausts. I was told they tested 70cc at 40psi. Both engines ran previously without this issue. Thoughts?
     
  2. paulswagelock

    paulswagelock Well-Known Member

    Oct 25, 2010
    pa
    2018 SDX 270 OB 300 Verado
    Verado 300
    Normally I would say stuck injector but not if they all tested good. Run it and monitor.
     
  3. TheBobC

    TheBobC New Member

    27
    Sep 21, 2017
    Pompano Beach, FL
    2006 340 Sundancer with Sportsman Package
    Original C80, Raymarine Radar and ST6001 Auto Pilot
    8.1 Horizons
    I would have thought that if only one engine. It is the fact that both engines are putting out a very large amount of fuel in to the water...extremely noticeable sheen. Hate to dump that in to the water...as well as not wanting to do any kind of engine damage.
     
  4. PlayDate

    PlayDate Well-Known Member

    Dec 25, 2006
    Washington DC
    1994 370 Express Cruiser
    454 Mercruisers
    I have to question what they did to the injectors. Something isn't right. Did they give you a set that belonged to someone else?
     
  5. scoflaw

    scoflaw Well-Known Member

    Aug 10, 2011
    cape cod mass, cape coral fl
    1999 Powerquest legend 260 sx
    502 mpi Bravo 1
    Give us a recap on what your issues have been this season, and what you have done to resolve them.
     
  6. TheBobC

    TheBobC New Member

    27
    Sep 21, 2017
    Pompano Beach, FL
    2006 340 Sundancer with Sportsman Package
    Original C80, Raymarine Radar and ST6001 Auto Pilot
    8.1 Horizons
    Ugh...

    March - Found water in oil of port engine. Very low compression in cylinder 1 and 5. Pulled heads, valve job and recondition both, problem solved.
    April - Starboard engine blew and seized up. Had been running 3400 rpms for a couple hours on the way to Bimini. Temperature was normal, oil pressure normal at time of failure. Pulled engine and disassembled. Piston number 7 had superheated and disintegrated. Pieces throughout engine. Block destroyed, cam destroyed, etc. Purchased long block and reassembled and put in boat. Started and ran well. As an abundance of caution, pulled injectors (13 yrs old, never serviced) on both engines, sent out to service, reinstalled. Now have the mentioned fuel in water on both engines.

    My concern is that the mechanic is saying definitely a problem with the injector job. I fear the injector guy will say must be other problem. They had said when I got them back that they were in pretty dirty, but all good at 70cc at 40psi.
     
  7. PlayDate

    PlayDate Well-Known Member

    Dec 25, 2006
    Washington DC
    1994 370 Express Cruiser
    454 Mercruisers
    I noticed this on your first post in this thread. I have worked on a lot of fuel injection systems and I usually use lbs/hr as the way to identify the injector. 8.1s came with 42 lbs/hr injectors that flow 440 ccs per minute.

    Something isn't right with what you have been told. While I don't use cc's often...if you multiply 70cc times 60 minutes and divide it by the specific weight of gasoline you get 6.9 lbs per hour.



    Is it possible for you to borrow a set of injectors from your mechanic? That would sort this out in quick order. Also, please post the serial numbers of your engines.
     
    Last edited: Aug 18, 2019
  8. scoflaw

    scoflaw Well-Known Member

    Aug 10, 2011
    cape cod mass, cape coral fl
    1999 Powerquest legend 260 sx
    502 mpi Bravo 1
    Agree that numbers don't sound right. I just bought a set of injectors for my 502 and the flow sheet had them flowing around 550 cc/min @ 4 bar.

    So if your engines were running fine and the only thing you did was have your injectors cleaned and changed nothing else and now this...what else could it be ? Got to be them.
     
  9. TheBobC

    TheBobC New Member

    27
    Sep 21, 2017
    Pompano Beach, FL
    2006 340 Sundancer with Sportsman Package
    Original C80, Raymarine Radar and ST6001 Auto Pilot
    8.1 Horizons
    Agree...sad to say. Waiting to call shop tomorrow
     

Share This Page

Show Sidebar